Lots of script-driven apps, particularly paid content management systems, encrypt their files to ensure that they won't be reverse engineered or tampered with. Many of them use an application known as ionCube PHP Encoder to do this, so when you buy a paid script and you intend to install it in a web hosting account, a software instrument known as ionCube Loader needs to be present on your server. Without having it, you cannot install the script or if you somehow manage to do that, it won't operate effectively due to the fact that almost all of the script code will be encrypted to a degree where it can't be interpreted. That is why, you should make sure that ionCube Loader is present when you get a new website hosting account and you would like to use some paid web app. If you get a shared hosting account and the instrument is not present, it can't be added as the whole server PHP environment will have to be compiled again.

IonCube in Cloud Website Hosting

IonCube Loader comes with all of the cloud website hosting packages that we offer, so when you need it in order to install and execute a script application which requires it, you can activate it with a click from the Advanced section of your Hepsia Control Panel. As you are able to switch the PHP version that's active for your account in the same section, you'll have to enable the tool for each new version that you set. If you're more skillful, you're able to employ a php.ini file in a domain or subdomain folder and set the PHP version as well as the status of ionCube Loader for that particular site only, without affecting the whole account. This way you're able to manage both new and older script applications for multiple websites within the same account - a thing that you will not be able to do with many other web hosting providers available on the market.

IonCube in Semi-dedicated Servers

In case you buy a semi-dedicated server plan from us, you will be able to take advantage of any kind of script-driven app that needs ionCube Loader as the software tool comes with all of the servers which are a part of our innovative cloud hosting platform. In addition, we support various versions of PHP, and if you move from PHP 4 to 5.2 or 5.3, for instance, you can enable ionCube for that particular version with just a click from your Hepsia Control Panel. Our platform will remember your decision, so if you switch back to the earlier version of PHP, the software instrument will already be active. For more tech-savvy users, we also offer the option to choose the PHP version and whether ionCube will be active or not for a particular domain without altering the settings for the entire web hosting account. This is done by putting a php.ini file inside a domain folder with a couple of lines of program code.